Thursday, December 3, 2020
Video Library

Volvo Central Electronic Module CEM Removal Procedure for 1999 – 2004 XC90, XC70, V70, S60, S80

Today we’re featuring a step-by-step tutorial on how to safely remove your Central Electronic Module (CEM) from your Volvo.
This tutorial applies to the following models:
1999 – 2004 S80
2001 – 2004 S60, V70, XC70
2003 – 2004 XC90
For more tech tips, and to see a full list of our products and services, please visit www.xemodex.com.

28 Comments

  • Hello, my mother drives a 2003 Volvo s80. Her right low beam headlight is out, the fuses are fine and the bulb has been changed. Also, her instrument cluster is going haywire. It works on occasion and then shuts off. Could this be a CEM issue?

    • Hi Emili,
      I spoke to our tech regarding your situation and he said he does not suspect a CEM. He said that the same power supply for both the left and right head lights is controlled by the CEM. It is separated at the fuse box through Fuse #18 (left head light) and Fuse #17 (right head light). Verify that there is power at these fuses and at the connector to the head light.
      Regarding your DIM (instrument cluster), he said that the symptoms you are facing does seem to be a failing DIM. We recommend that you send your DIM in for repair. You can place an order on our website http://www.xemodex.com or over the phone with a customer support rep toll-free at 1-888-712-2525. Once you place an order, we will email you pre-paid shipping labels so that you can ship your part to our facility for repair.
      More information about our DIM (instrument cluster) Repair and Return service: http://xemodex.com/us/product/driver-information-module-for-volvo-vo-1030-862473-10-20/
      If you have any further questions, please do not hesitate to contact us again. Have a great day!
      AK

  • Hi I have a Volvo S60 2.5 Turbo 2004 we been having problem with the car, it looses the turbo and the Board stop working it does not mark anything just goes black, the windows do not go up or down and the direction lights does not work either, I took the car to the dealer and he said that it could be the CEM.. please help me
    We used to have the problem only when it was very warm the weather or the car was left under the sun now it does it more often and even in rainy days.

  • I have a Volvo S80 2000 that I have replaced the CEM relay module (part#30657629) about 2 years ago and I really do not want to go thru Volvo Dealer for the repairs again at a high cost! Can this CEM unit be sent in to you for repair? I’m thinking that then it will not need to be reprogrammed to put back in?
    Thank You!

    • Hi Robyn,
      I spoke to our tech and he said it seems odd that the dealer replacement only lasted 2 years. How did you determine that the problem is with the CEM? Are you able to supply us with the fault codes and symptoms?
      We offer a CEM Program Transfer service where you send us your existing unit and we transfer the programming to one of our remanufactured units from stock. Our CEM program transfer service includes transfer of the software, VIN number, key codes, mileage as well as the original CEM configuration and settings. The CEM will not need any additional reloads or calibration. The CEM also comes with a Lifetime Warranty for as long as you own the car.
      You can learn more about our CEM Program Transfer service on our website here:
      http://xemodex.com/us/product/central-electronic-module-program-transfer-for-volvo-vo-1070-30657629-00-22/
      You may place your order online at http://www.xemodex.com or over the phone with a Sales Rep toll-free at 1-888-712-2525. Please do not hesitate to contact us if you have any questions. Have a great day!
      AK

  • Hi I have a 1999 s80 non turbo and ever since I’ve gotten the car which was about a year ago it’s always throw a break failure code, we’ve replaced the BCM and got rid of the bad battery that was given with the car and it still gives me that code and when that code is showing all my gauges fall except my gas. Also my lights for the heat and ac on the main console don’t light up except for a small part on the passenger side. If I get the code while driving the car still drives but if the code is on when I go to start the car it won’t start and if it does it won’t shift out of park. I always have to disconnect the battery when this happens sometimes for 5 minutes sometimes for 2 days, please help.

    • Hi Mariah,
      I spoke to our tech and he said it looks like there may be more of a brake issue because both the hi speed (brakes) and low speed (gauges, heat/AC, not able to get out of park) are affected. This suggests that the fault may be in the Central Electronic Module (CEM).
      He recommends viewing our DIM/CEM diagnostic flow chart on our website:
      http://xemodex.com/us/knowledgebase/dimcem-low-speed-can-diagnostic-flow-chart/
      If you have any further questions, feel free to contact us toll-free at 1-888-712-2525 and ask to speak to our tech support. Thank you.
      AK

  • Dear Madame or Sir
    I am an italian owner of a Volvo S80 2,5 Td 2000.
    I am in big trouble with it after i had a battery drain for my fault that i recovered by a battery wire link with another battery car.
    The engine started immediatly but i first noted an unespected low beam lights flashing.
    After that i faced several electronic troubles: mistake message from the inboard computer about the ABS system. central locking very faulty as well, dashboard and control intruments out of order or working and after a while not, low beam lights that remain turned on after i switch off the car, clock and outside temperature indicator not working.
    The only thing that seem to work properly is the engine.
    Now the question is: it may be a CEM failure even i don’t undestand how the engine seems not to be affected at all. Is it possible?
    In the case of this possibility how would i face this matter?
    It’s an old car and i don’t think it’s worthy to spend more the 1200 Euro to buy a brand new CEM from a Volvo authorised dealer.
    Do you have any suggestion where to buy such Cem? Am i guaranteed that if i replace it i will solve the matter?
    Any suggestion is very much appreciated.
    Do you have any italian mechanic where to address me?
    Thank you in advance.
    Leonardo Martini

    • Hi Leonardo,
      Our tech suspects a CEM issue, but he suggests that you take your vehicle to a Volvo repair shop to get diagnosed and read for DTC codes. Please provide us with the specific fault codes from your vehicle so that we can further assist you. We do ship to Italy. If you would like to purchase a CEM repair service, please e-mail sales@xemodex.com. Our sales staff will guide you through the ordering process. Thank you.
      AK

  • I Own a Volvo S60 2004 Chassis No. YV1RS61S542364178 Engine No. 3215776 Km’s run Aprox. 90,000
    I have been experiencing the following problems over the last 6-8 months :
    the car was running fine about eight month’s ago, came home from work and the next day got in and started the engine the all instruments and gauges started and immediately died and the engine warning light came on, the indicators were not working, the head lights were on despite the light switch being in the off position wipers worked however it was only working on fast mod and when switching the wipers it would stop mid way and not go back to the rest area and while driving there was a noticeable reduction in acceleration and the Engine power seemed to have been massively reduced.
    on the first occasion I called the Volvo Agent dealership in Doha, Qatar and was told to bring the car in.
    I requested a recovery vehicle and as the recovery arrived and I started the the car all was back to normal except for the Engine Light being still on, so the car was sent to the dealership and the C E M was cleaned and reset, however since then it has occurred several times, sometimes it would run for two to three weeks, however as time has gone on the dependability of the car has reduced.
    The dealership have recommend replacement of C E M (Central Electronic Module) and claim that it cannot be repaired and must be programmed for each individual chassis number and cannot be reprogrammed for another Volvo.
    My question is : can the CEM be repaired or replaced with a reconditioned one I am also prepared to send the CEM to you, and at what cost. please bear in mind I live in the middle east in Qatar, and what assistance will I need from the local Volvo dealership?
    Also do you have a telephone number that I can contact you on for more information.
    I would appreciate your feed back at your earliest convenience.
    Regards, Joseph Bayatti

  • I have a 2002 Volvo S60 2.4t and my dashboard started to act up. At times it would work fine and at times it would act up or not work at all. Sometimes the widows will work and sometimes not. The trunk lid will sometimes work and sometimes it won’t. The text box will also work sometimes and at times it will be acting up. I have replaced the battery but still the same symptoms.

    • Hi Frank,
      I spoke to our tech and he said that it is very rare for the instrument cluster/DIM (driver information module) on your particular year to fail. What you should pay close attention to is if anything else goes down at the same time such as your power windows, seats, etc. This is an indicator that you may have a faulty CEM (central electronic module). He suggests that you call our tech support while you are performing these diagnostics for further instruction. You may call us toll-free at 1-888-712-2525 (US & Canada only). If you are located outside North America, you may e-mail us at info@xemodex.com. Thank you.
      AK

  • I have a 2001 S60 diagnosed by Volvo dealer needing a new CIM..Price is $1400 cant do that with 200000 miles…its almostr waht the car is wort LOL
    Im a good mechanic and watching your video a few times looks like thhs can be done..but…do i need a new cem, or a used same make and model and put it back in as shown..or is there programing involved..??

  • Hi,
    I have a Volvo XC90 2003 and what’s happening is when my car get the on road weather 30 degrees Celsius the car shoot down all electronics components but still drives but not working electrical parts like indicators, brakes lights. I suspect this problem is a Cem module but when is cold weather the cars works fine. I thinking to buy a new one or fix this one but I don’t know if I have to use the OBD II to put this CEM module Back when is fixed or if I buy new one how to synchronise my keys and all commands in my car I think if I buy a used one this can be work in my car?

    • Hi Diego,
      I spoke to our tech and he said it could be a CEM, but he needs more information about your vehicle to give you an answer. Please contact us toll-free 1-888-712-2525 (US & Canada) and ask to speak to our tech specialist. Alternatively, you can e-mail us at info@xemodex.com. Thank you!
      AK

  • I have a Volvo v50 24i and driving this morning the ABS anti skid service warning came on and the power was about 50% with the gas floored in a 35 mph zone. The windsheild wipers started by themselves and I could not turn them off and the gauges zeroed out plus the signal lights would not work??? The car has about 186k miles on it so I do not want or have the money for an expensive repair??? Can you help? do you know what it might be?

  • Also I forgot to mention with my previous comment that I had trouble getting the plastic key out of the ignition, it would not make that final turn for a few minutes??? I am so upset and hope that it is something easy and inexpensive to fix?

    • Hello,
      Our tech suggests performing a hard battery reset as this will reboot the memory in the car’s computer. He said sometimes the memory develops bad habits, and performing a hard reset will remedy this issue. To perform the hard battery reset, (with the vehicle off) disconnect the negative terminal first, and then the positive terminal. Make sure the cables are away from the battery and hook the cables together with tape for 12 hours. After 12 hours have passed, with your key in position II, reconnect the positive terminal of the battery first, and then the negative terminal. Use the car normally and monitor any codes that are posted on the dash. If any codes are posted on your dash, go to your local shop to have your vehicle scanned for diagnostic trouble codes (DTC).

  • Hello, i have a 2008 xc90 and I’m having some electronic issues since i replaced the battery: back windows does open or closes, no central locking from the keys neither from the inside button, battery light always on, noise on the back, flashing lights. It seems that the entire electronic is going crazy, do you think it can be the CEM or just a fuse? Thank you

    • Hi Camille,
      I spoke to our tech and he said that it sounds like the REM has gone to sleep. He suggests to perform a hard battery reset on the vehicle which should solve your problem. To perform the hard battery reset, (with the vehicle off) disconnect the negative terminal on the vehicle’s battery, and then the positive terminal. Make sure the cables are away from the battery and hook the cables together with tape for at least 12 hours (preferably overnight). After 12 hours have passed, with your key in position II, reconnect the positive terminal of the battery first, and then the negative terminal. Use the car normally and monitor any codes that are posted on the dash. If any codes are posted on your dash, go to your local shop to have your vehicle scanned for diagnostic trouble codes (DTC).
      If you have any further questions, please do not hesitate to contact us toll-free (US & Canada customers) at 1-888-712-2525 or alternatively by sending an e-mail to info@xemodex.com. Thank you.
      AK

  • ok here are my symptoms in which makes me think its the cam after reading online reviews.
    I currently have the intake manifold off doing a pcv catch can and did the timing about to change the water pump and tensioners. ( i disconnected the battery to do this.)
    When i first bought the suv xc 90 2003 t6 the owner said it only needed new brake bulbs. changed them. nothing. changed all three tail lights out and reverse lights out. (running lights worked). tried to change brake relay didn’t work. but i noticed that it was 5 prong and my old was 4 prong.( i have one on the way.)
    when test driving it all dash lights/ gauges went out after 10 minutes and gas gauge never worked. the owner had a used dash assembly ordered off eBay in the trunk so i installed it same thing on then off after 10 minutes or so. radio worked, windows worked, heater/ac worked.
    After taking the engine apart and cleaning up the oil mess it started to get dark i turned on the battery and put the alarm on it. every thing seemed fine. i went back out to the car the the power keys and rear doors did not work I unlocked it manually. turned the key to position one tho remove shunts and relays to see if the rear brake lights would come on dash came on tried to roll down window very slow seemed like battery dying. turned it off then back to position 1 and nothing no alarm no keys no dash no power.
    Noise under the dash where its located just happened last time i opened the door. weird noise. nothing works on the car at all any more.
    Theres also a weird box fell out when looking at the CEM when I opened the case like something was added to the vehicle. is that the gps looks like a coaxial cable is hooked to it. but the letters are worn out.
    Could this be the CEM the upper back brake light is not working so this is whats making me think it is. will this stop me from passing deq./ emissions. i have not seen a check engine light on yet but also the dash keeps cutting out.

  • Hello,
    I’ve a Volvo S60 D5 185hp (2006).
    I’ve a problem with the parking heater.. If I set a time or try to start directly from the menu, it doesn’t work… But if I connect a laptop I can start the parking heater and it works perfectly ( with delphi). Do you know what can be the problem? Why doesn’t work from the menu?
    Thank you
    Istvan

  • I have a 2004 S60, 152,000 miles. Two days ago the car quit just down from my house while at about 45 MPH. Afterwards, it would not turn over, but all the lights were on. I reset the computer the next morning by clamping the Positive and Negative cables together, and it started right up. Again, at the same spot in the road from my house it died again at about 45MPH. This time I cannot start the vehicle (cranks, but clicks and sputters), there are NO lights anywhere, and the Speedometer and Tachometer are stuck at 45MPH / 2500RPM. NO other electrical items work. I pulled the battery and it checked fine. I pulled the dashboard out and checked the wires, but all good.
    Could this be a CEM issue?
    Thank you!
    Don~

  • Hello, Tried to ugrade firmware of the cem, an error has ocurred and now the cem is not communicating with vida nor working, the lights flashes and the relays are on/off about every second. Is a way to repair it? The car before the upgrade was working with no problems.
    Regards.

Leave a Reply